heartbleed

By now, you have probably heard of the Heartbleed bug that puts users’ passwords on dozens of popular websites at risk because of a security vulnerability in OpenSSL software.

The depth and breadth of this bug is quite massive, so we wanted to give our clients some advice on what to do and any services of ours that may have been affected.

First and foremost, whether you are a client or not, it’s strongly advised you change your passwords on the sites that have been affected. You can find a clear and extensive list in this table at Mashable.com.

Next, for clients who host with Jackson Sky (on our servers at Media Temple), rest assured that the services we use at Media Temple (GRID and dv 4.0 Server) were not vulnerable or affected.

Lastly, it seems that the security of WordPress is largely based on your hosting provider, so you will need to check with them about whether they were affected. (Again, our servers with Media Temple were not.) If they were, you will want to change your admin passwords immediately. You will also want to update your WordPress to the most recent version, which has the strongest level of security.

We don’t think this is the last we will hear of Heartbleed, so please stay tuned for any additional updates and information.

Share this article
Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *